labelme.spec 830 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # -*- mode: python -*-
  2. # vim: ft=python
  3. import sys
  4. sys.setrecursionlimit(5000) # required on Windows
  5. a = Analysis(
  6. ['labelme/__main__.py'],
  7. pathex=['labelme'],
  8. binaries=[],
  9. datas=[
  10. ('labelme/config/default_config.yaml', 'labelme/config'),
  11. ('labelme/icons/*', 'labelme/icons'),
  12. ],
  13. hiddenimports=[],
  14. hookspath=[],
  15. runtime_hooks=[],
  16. excludes=[],
  17. )
  18. pyz = PYZ(a.pure, a.zipped_data)
  19. exe = EXE(
  20. pyz,
  21. a.scripts,
  22. a.binaries,
  23. a.zipfiles,
  24. a.datas,
  25. name='labelme',
  26. debug=False,
  27. strip=False,
  28. upx=True,
  29. runtime_tmpdir=None,
  30. console=False,
  31. icon='labelme/icons/icon.ico',
  32. )
  33. app = BUNDLE(
  34. exe,
  35. name='Labelme.app',
  36. icon='labelme/icons/icon.icns',
  37. bundle_identifier=None,
  38. info_plist={'NSHighResolutionCapable': 'True'},
  39. )