labelme.spec 777 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # -*- mode: python -*-
  2. # vim: ft=python
  3. a = Analysis(
  4. ['labelme/__main__.py'],
  5. pathex=['labelme'],
  6. binaries=[],
  7. datas=[
  8. ('labelme/config/default_config.yaml', 'labelme/config'),
  9. ('labelme/icons/*', 'labelme/icons'),
  10. ],
  11. hiddenimports=[],
  12. hookspath=[],
  13. runtime_hooks=[],
  14. excludes=['matplotlib'],
  15. )
  16. pyz = PYZ(a.pure, a.zipped_data)
  17. exe = EXE(
  18. pyz,
  19. a.scripts,
  20. a.binaries,
  21. a.zipfiles,
  22. a.datas,
  23. name='labelme',
  24. debug=False,
  25. strip=False,
  26. upx=True,
  27. runtime_tmpdir=None,
  28. console=False,
  29. icon='labelme/icons/icon.ico',
  30. )
  31. app = BUNDLE(
  32. exe,
  33. name='Labelme.app',
  34. icon='labelme/icons/icon.icns',
  35. bundle_identifier=None,
  36. info_plist={'NSHighResolutionCapable': 'True'},
  37. )