labelme.spec 908 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # -*- mode: python -*-
  2. # vim: ft=python
  3. block_cipher = None
  4. a = Analysis(
  5. ['labelme/main.py'],
  6. pathex=['labelme'],
  7. binaries=[],
  8. datas=[
  9. ('labelme/config/default_config.yaml', 'labelme/config'),
  10. ('labelme/icons/*', 'labelme/icons'),
  11. ],
  12. hiddenimports=[],
  13. hookspath=[],
  14. runtime_hooks=[],
  15. excludes=['matplotlib'],
  16. win_no_prefer_redirects=False,
  17. win_private_assemblies=False,
  18. cipher=block_cipher,
  19. )
  20. pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
  21. exe = EXE(
  22. pyz,
  23. a.scripts,
  24. a.binaries,
  25. a.zipfiles,
  26. a.datas,
  27. name='labelme',
  28. debug=False,
  29. strip=False,
  30. upx=True,
  31. runtime_tmpdir=None,
  32. console=True,
  33. icon='labelme/icons/icon.ico',
  34. )
  35. app = BUNDLE(
  36. exe,
  37. name='labelme.app',
  38. icon='labelme/icons/icon.icns',
  39. bundle_identifier=None,
  40. info_plist={'NSHighResolutionCapable': 'True'},
  41. )