labelme.spec 879 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # -*- mode: python -*-
  2. # vim: ft=python
  3. import sys
  4. sys.setrecursionlimit(5000) # required on Windows
  5. a = Analysis(
  6. ['labelme/__main__.py'],
  7. pathex=['labelme'],
  8. binaries=[],
  9. datas=[
  10. ('labelme/config/default_config.yaml', 'labelme/config'),
  11. ('labelme/icons/*', 'labelme/icons'),
  12. ('labelme/translate/*.qm', 'translate'),
  13. ],
  14. hiddenimports=[],
  15. hookspath=[],
  16. runtime_hooks=[],
  17. excludes=[],
  18. )
  19. pyz = PYZ(a.pure, a.zipped_data)
  20. exe = EXE(
  21. pyz,
  22. a.scripts,
  23. a.binaries,
  24. a.zipfiles,
  25. a.datas,
  26. name='labelme',
  27. debug=False,
  28. strip=False,
  29. upx=True,
  30. runtime_tmpdir=None,
  31. console=False,
  32. icon='labelme/icons/icon.ico',
  33. )
  34. app = BUNDLE(
  35. exe,
  36. name='Labelme.app',
  37. icon='labelme/icons/icon.icns',
  38. bundle_identifier=None,
  39. info_plist={'NSHighResolutionCapable': 'True'},
  40. )